HealthTalkie

Talk About Health and Its related Topics

 

Adjusting Audio Delay In MP4 Files

by Funkstar De Luxe
Is there a way to do this without re-encoding the whole file? I have some files which I encoded with StaxRip which seem to have a delay of around 150ms. I don't want to re-encode them because I'll loose quality and time :-(

Surely there is a way to get both the video and audio data out of a mp4 container, adjust it then glue it back together? Or have I got this all wrong?

Tony

  • with Yamb...check Import Settings in Options tab then put your delay in the edit area.
    - Kurtnoise, 8 years ago
  • In Yamb, decal cannot be negative, why?
    - Sirber, 8 years ago
  • Maybe a missing...
    - Kurtnoise, 8 years ago
  • I think you need to extract both audio and video into a separate new ".mp4" and then reimport them with "mux", adding a delay of 150 ms to the audio, if you need negative for audio, just delay the video.

    Download YAMB 1.5 from the llink above "Kurtnoise13's footnote", under "options" browse for mp4box, it must be located somewhere in staxrip's folder
    - kotrtim, 7 years ago
  • moved
    - bond, 6 years ago
  • I encode some movie, but i encode sound with last foobar 0.92 newermind on this, my problem is because foobar dosen't have delay option i must delay when muxing audio and video. I enter delay -224 and mux is finished via yamb but delay is not applayed. audio file is mp4 new nero encoder. I think is problem in mp4box, because i try to manualy set delay value and try many combinations bu nothing change foobar always show same duration. I have mp4box from lastest yamb 1.6 and yamb some new kurnoise13 build. THanks
    - shon3i, 6 years ago
  • Already explained...AFAIK none existing mp4 splitters/parsers are able to detect negative values in mp4. That's why you have this.
    - Kurtnoise, 6 years ago
  • Already explained...AFAIK none existing mp4 splitters/parsers are able to detect negative values in mp4. That's why you have this.
    same thing is for positive values. That smell like bug. I try even and put positive value but duration of file wan't change
    - shon3i, 6 years ago
  • Already explained...AFAIK none existing mp4 splitters/parsers are able to detect negative values in mp4. That's why you have this.indeed a bad thing. i am not sure what the latest haali splitter does with the elst atom (dunno right know if thats delay related)

    someone should bug haali and gabest to support those thingies :D
    - bond, 6 years ago
  • indeed a bad thing. i am not sure what the latest haali splitter does with the elst atom (dunno right know if thats delay related)

    someone should bug haali and gabest to support those thingies
    Do you mean that bug come from Haali and Gabest ? . This bug doesn't come form Mp4box ?
    - thuongshoo, 6 years ago
  • i wouldnt call this a bug, its simply a missing feature
    - bond, 6 years ago

Comment